Could not load type ''System.Web.UI.Compatibility.CompareValidator'' from assembly ''System.Web.Extensions, Version=1.0.61025.0

If you are trying to use ASP.NET ASJAX V1.0 (for ASP.NET V2.0) and you see this error:

 

Parser Error Message: Could not load type 'System.Web.UI.Compatibility.CompareValidator' from assembly 'System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'.

Source Error:

Line 42: 			</controls>
Line 43: 			<tagMapping>
Line 44: <add tagType="System.Web.UI.WebControls.CompareValidator" mappedTagType="System.Web.UI.Compatibility.CompareValidator, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>Line 45: 				<add tagType="System.Web.UI.WebControls.CustomValidator" mappedTagType="System.Web.UI.Compatibility.CustomValidator, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
Line 46: 				<add tagType="System.Web.UI.WebControls.RangeValidator" mappedTagType="System.Web.UI.Compatibility.RangeValidator, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>

This is because the validators were removed from the latest release. The default Web.config that comes with the RTM release no longer has the validators in the <tagMapping> element.

Here is a pointer to a blog post that describes how you can download the compatibility validators: http://weblogs.asp.net/scottgu/archive/2007/01/25/links-to-asp-net-ajax-1-0-resources-and-answers-to-some-common-questions.aspx

 

 

Add Feedback